Advertisement

Uploading speed for backups is only ~100 KB/s

Home Forums Crashplan on Other NAS systems Uploading speed for backups is only ~100 KB/s

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #943

    krneki
    Participant

    I’m facing very slow uploading speed with Crashplan for business. It’s usually around 100 KB/s, which means that it would take like 4 months for my HDDs to upload backups. This is absolutely useless.

    I have already tried to set java mx=2048, dataDeDupAutoMaxFileSizeForWan=1, socketSendBufferSize=1048576, socketReceiveBufferSize=1048576 but it doesn’t help at all. My upload speed (FTTH) is otherwise 10 Mbps, so Crashplan is utterly slow.

    Are there any other suggestions to increase the uploading speed?

    #944
    an
    an
    Keymaster

    Hi,

    What system are you using and how much RAM do you have? If you have 2Gb don’t set it to use all of it (even though that’s not the likely culprit, it will make everything sluggish).

    Also, do you have just one backup set or multiple?

    Advertisement
    #946

    krneki
    Participant

    I have set a single backup for the system SSD and a secondary HDD. I’m running Windows 10 x64 at 6 GB RAM and Intel Core i7.

    #947
    an
    an
    Keymaster

    I have set a single backup for the system SSD and a secondary HDD. I’m running Windows 10 x64 at 6 GB RAM and Intel Core i7.

    As you’re using Windows you might want to set the upload speeds to specific values, in case it’s set to maximum. If your network router doesn’t handle QoS properly (which many don’t) then it might try to use up all the the available bandwidth, from there causing a connection bottleneck, causing Crashplan to stop uploading properly as well.

    Have you set data de-dup to Minimal in your “Advanced Backup Settings” (screenshot of this article https://crashplan.setepontos.com/crashplan-performance-tips/ )?

     

    #949

    krneki
    Participant

    Yes, data de-dup is already set to minimal. Router is more than fast enough (802.11ac) and can easily handle much higher speeds. QoS is disabled and so is all P2P software. Crashplan is the only exception that hits such low speeds.

    From the config:
    <dataDeDupAutoMaxFileSize>1073741824</dataDeDupAutoMaxFileSize>
    <dataDeDupAutoMaxFileSizeForWan>1</dataDeDupAutoMaxFileSizeForWan>
    <dataDeDuplication>MINIMAL</dataDeDuplication>
    <encryptionEnabled>true</encryptionEnabled>

    #950
    an
    an
    Keymaster

    Sorry, but I’m out of ideas – if you’re sure to have restarted the Crashplan service after making those changes there should be something else going on with your computer that’s messing up with it.

    Also, don’t forget that issuing “java mx” is not persistent and the java heap will probably be reset after starting the service.  2Gb ought to be ok for at least up to 2Tb of data, although it depends on the number of files as well.

    If setting your upload speed to a fixed value did not help, the other thing I can suggest is to try to set your backup to disable both encryption and compression. Finally, you could also change the processor usage settings, but with your specs it’s unlikely that will change anything.

     

Advertisement
Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.
https://i2.wp.com/crashplanbackup.com/wp-content/uploads/2015/11/crashplan-fix.png?fit=512%2C512&ssl=1https://i2.wp.com/crashplanbackup.com/wp-content/uploads/2015/11/crashplan-fix.png?resize=150%2C150&ssl=1krnekiHome › Forums › Crashplan on Other NAS systems › Uploading speed for backups is only ~100 KB/s This topic has 5 replies, 2 voices, and was last updated 5 months, 2 weeks ago by  an.Viewing 6 posts - 1 through 6 (of 6 total) Author Posts April 9, 2017 at 19:46 #943 krnekiParticipant I’m facing...Unofficial Help & Support Forum for CrashPlan, Cloud Backup and Cloud Storage Solutions - Find Help, Support and a Knowledge base

Here's what other Users are reading:

Affiliate Links
Advertisement

By continuing to use the site, you agree to the use of cookies. more information

The cookie settings on this website are set to "allow cookies" to give you the best browsing experience possible. If you continue to use this website without changing your cookie settings or you click "Accept" below then you are consenting to this.

Close