Advertisement

CrashPlan PRO 4.6.0-0038 (fix for 4.7.0)

Home Forums CrashPlan on Synology DiskStation NAS CrashPlan PRO 4.6.0-0038 (fix for 4.7.0)

Viewing 15 posts - 1 through 15 (of 19 total)
  • Author
    Posts
  • #427

    George
    Participant

    Hi All,

    Really appreciate everyone’s effort on sites like this, you all have been incredibly helpful in the past, so I am hoping there is a solution for the latest round of CrashPlan issues.

    I am running a DS415+ with DSM 6.0-7321, Update 6 in a Windows Server 2008R2 domain.

    CrashPlan PRO 4.6.0-0038.

    The update went through last night, and now will not start. When I try to start, it hangs for several minutes and then reverts to “stopped.”

    Looking at the log file shows the last line as “Synology extracting upgrade from /var/packages/CrashPlanPRO/target/upgrade/1435813200470_317.jar

    It is my understanding that DSM 6 is now using 7 zip, so I am not sure if that is the reason the extraction is hanging.

    I used the old unzip commands from the past, but do not know how to transcribe them into 7zip commands.

    Any help would be appreciated in getting this back up and running.

    Many thanks

    #430
    an
    an
    Keymaster

    I used the old unzip commands from the past, but do not know how to transcribe them into 7zip commands. Any help would be appreciated in getting this back up and running. 

    Hi,

    Yeah, the post discussion threads at patters and other sites are very confusing, that’s why I thought of creating this forum. There isn’t a lot of movement here, but hey, if it helps someone in someway that’s ok.

    So, 7-zip. You should be able to do the extraction with commands as such:

    sudo 7z e -y /var/packages/CrashPlan/target/upgrade/1435813200470_317.jar “*.jar” -o/var/packages/CrashPlan/target/lib/
    sudo 7z e -y /var/packages/CrashPlan/target/upgrade/1435813200470_317.jar “lang/*” -o/var/packages/CrashPlan/target/lib/

     

    Cheers

    Advertisement
    #447

    George
    Participant

    Thanks much for the reply, I really do appreciate it.

    I seem to have the commands down, however, I get an error that states “there is no such archive.”

    The log file from the DSM says the “Synology is extracting the file from …(as above)” Do I have to stop that extraction first? If so, how?

     

    #448
    an
    an
    Keymaster

    Have you listed the contents of /var/packages/CrashPlan/target/upgrade/  to see what’s actually there?

    i.e.

    cd /var/packages/CrashPlan/target/upgrade/
    
    ls -l
    #449

    George
    Participant

    When I do a ls -l, I see a bunch of .bat and .sh files. There is one more subdirectory “UpgradeUI.” if I go to that and do an ls -l, it returns “total 0.”

    I have to head out for a while, but will check back this afternoon. Thanks again for the help!

     

    #450
    an
    an
    Keymaster

    Trying to start CrashPlan from DSM’s Package Manager should make it try to self-upgrade and download the jar file or  running the client again (check if the ui_token info is still accurate).

    At that point you should see something like:

    @hive:/var/packages/CrashPlan/target/upgrade$ ls -l
    
    total 46388
    
    -rw-r--r-- 1 root root 47456700 May  9 18:22 1435813200470_317.jar
    
    -rw-rw-r-- 1 root root      127 May  1 22:40 start.bat
    
    -rw-rw-r-- 1 root root       92 May  1 22:40 startDesktop.bat
    
    -rw-rw-r-- 1 root root      135 May  9 14:14 startDesktopLinux.sh
    
    -rw-rw-r-- 1 root root      312 May  9 14:14 startDesktop.sh
    
    -rw-rw-r-- 1 root root      137 May  9 14:14 startDesktopSolaris.sh
    
    -rw-rw-r-- 1 root root       87 May  9 14:14 startFirst.sh
    
    -rw-rw-r-- 1 root root      211 May  9 14:14 startLinux.sh
    
    -rw-rw-r-- 1 root root      247 May  9 14:14 start.sh
    
    -rw-rw-r-- 1 root root      213 May  9 14:14 startSolaris.sh
    
    drwxrwxr-x 2 root root     4096 May  1 22:40 UpgradeUI

     

    Cheers

    #454

    George
    Participant

    Just caught this before heading out. Yes, I see everything in there except the .jar file.

     

    I have uninstalled and reinstalled CrashPlan Pro, so I don’t know if that has anything to do with it.

    You mentioned checking if the ui_token info is still accurate. How would I verify that?

     

    #455
    an
    an
    Keymaster

    If you have been using CrashPlan for some time, you’ve probably have had to do it. It’s just a matter of checking the data inside .ui_info file on your Synology matches the one of your client CrashPlan app (Windows/Mac), except the client one end with you NAS’ ip address instead of 0.0.0.0 or similar.

    Check the link below for default locations for this file.

     

    Folder Locations for CrashPlan common system files

     

    I haven’t made the repair for 4.7.0 (not PRO) but I’m reading that they’ve changed the jar file structure again, so even with the jar there may be some other stuff to do to get it running.

    #477

    George
    Participant

    OK, I understand now. I ran the cat /var/lib/crashplan/.ui_info ; echo and got the number. the .UI info reads (like 4243, ee-aa-,0.0.0.0.

    I changed the last octet to the IP number of my Synology unit and modified the ui file on my Windows client. I also verified that the IP number is correct in the conf file in Program Files on my Windows machine.

    I am running Java 7 on my Synology. I notice Java 8 is available in the Package Center. Should I upgrade there?

    I am going to drill around in some other directories and see if I can find the archive file.

    Once again, thanks!

     

    #478

    Frode
    Participant

    Hi George

    I’m having exactly the same issue with my DS215j (DSM 6.)  and CrashPlan 4.6.0-0038. The Crhash Plan app has stopped and the log says;

    “Synology extracting upgrade from /var/packages/CrashPlanPRO/target/upgrade/1435813200470_317.jar”

    If you are able to drill around this issue I appreciate if you can post the answer.

    Thanks!

    #480
    an
    an
    Keymaster

    I am running Java 7 on my Synology. I notice Java 8 is available in the Package Center. Should I upgrade there?

    I’m not sure but I think it won’t make much of a difference.

    This issue we’re all experiencing is with upgrading to 4.7.0, which has additional steps to make it run. I haven’t been successful with this yet, but some apparently have:

    1. Using terminal, make a local copy of the file (it will be deleted after the next commands):
      1. cd /var/packages/CrashPlan/target

      2. sudo cp 1435813200470_317.jar 1435813200470_317.jar.BAK
    2. Extract “upgrade.cpi” from the jar file:
      1. sudo 7z e 1435813200470_317.jar upgrade.cpi

    3. And run these:
      1. cat upgrade.cpi | gzip -d -c – | /var/packages/CrashPlan/target/bin/cpio -i –no-preserve-owner

    Then try to start CrashPlan again and let us know how it went.

     

    Read the post below for updated instructions:

    CrashPlan 4.7.0 Installation Fix for Synology (1435813200470_317 May 2016)

     

     

    #496

    Frode
    Participant

    Hi all

    When I ran the “sudo cp 1435813200470_317.jar 1435813200470_317.jar.BAK” cmd I’m getting the error msg:

    cp: cannot stat ‘1435813200470_317.jar’: No such file or directory

    A dir cmd of this directoy showed no 1435813200470_317.jar file.

    [email protected] /var/packages/CrashPlan/target$ dir
    total 93940
    drwxr-xr-x 8 root root 4096 May 12 10:27 .
    drwxr-xr-x 19 root root 4096 May 12 07:51 ..
    drwxrwxr-x 2 root root 4096 May 12 10:27 bin
    drwxrwxr-x 2 root root 4096 May 12 10:27 conf
    -rw-r–r– 1 root root 441 May 12 07:13 install.vars
    drwxr-xr-x 6 2013 users 4096 May 19 2015 jre
    -rw-r–r– 1 root root 48547492 Jul 30 2015 jre-7-linux-i586.tgz
    -rwxr-xr-x 1 root root 126694 May 12 10:27 libjtux.so
    drwxrwxr-x 2 root root 4096 May 12 07:13 log
    drwxrwxr-x 3 root root 4096 May 12 07:11 skin
    -rw-r–r– 1 root root 23 May 12 10:27 syno_package.vars
    drwxrwxr-x 3 root root 4096 May 12 10:27 upgrade
    -rw-r–r– 1 root root 47472966 May 12 07:13 upgrade.cpi

    Maybe it’s because I have reinstalled CrashPlan. Hopefully  it will work for you George?

    Thanks again for your help.

     

     

     

     

    #498
    an
    an
    Keymaster
    #501

    George
    Participant

    It worked!

    I used the fix in the link, and modified the line;

    sudo cp /var/packages/CrashPlan/target/bin/cpio /bin/cpio  to CrashPlanPRO, because that is what I am using obvioulsy 🙂

    Then uninstalled/reinstalled. It started then stopped

    Modified the line JAVACOMMON=/volume1/@appstore/Java8/j2sdk-image/jre/bin/java  to java7, since I have not upgraded the java yet

    Let it sit for minute, then started the program. It started right up, i let it go for a full 10 minutes to see if it would stop again.

    I then updated the .ui_info files on my Windows client, logged in and it is running. I will be scanning/syncing for a while, since I have been down 3 days with this, but so far, so good.

    I will monitor during the day and let you know how it goes.

    Again, thank you so much for the help. Not sure what part of the world you are in, but if I ever get there, I will buy you a round of your favorite beverage! 🙂

    #502

    Frode
    Participant

    Great!

    Just a quick question. Only version 4.6 appears in the Package Center on my Synology. How did you downloaded v 4.7?

    Thanks in advance!

Advertisement
Viewing 15 posts - 1 through 15 (of 19 total)
  • The topic ‘CrashPlan PRO 4.6.0-0038 (fix for 4.7.0)’ is closed to new replies.
https://i2.wp.com/crashplanbackup.com/wp-content/uploads/2015/11/crashplan-fix.png?fit=512%2C512&ssl=1https://i2.wp.com/crashplanbackup.com/wp-content/uploads/2015/11/crashplan-fix.png?resize=150%2C150&ssl=1GeorgeHome › Forums › CrashPlan on Synology DiskStation NAS › CrashPlan PRO 4.6.0-0038 (fix for 4.7.0) This topic has 18 replies, 3 voices, and was last updated 1 year, 4 months ago by  an.Viewing 15 posts - 1 through 15 (of 19 total) 1 2 → Author Posts May 10, 2016 at 20:55 #427 GeorgeParticipant Hi All, Really appreciate everyone’s...Unofficial Help & Support Forum for CrashPlan, Cloud Backup and Cloud Storage Solutions - Find Help, Support and a Knowledge base

Here's what other Users are reading:

Affiliate Links
Advertisement

By continuing to use the site, you agree to the use of cookies. more information

The cookie settings on this website are set to "allow cookies" to give you the best browsing experience possible. If you continue to use this website without changing your cookie settings or you click "Accept" below then you are consenting to this.

Close